YesNoOk
avatar

nasty sound when using the backspace key in a empty messagebox (Read 3151 times)

Started by geskill, October 14, 2010, 15:58:57
0 Members and 1 Guest are viewing this.
#1
nasty sound when using the backspace key in a empty messagebox |
October 14, 2010, 15:58:57
Hey,
yesterday i switched to your messagebox-plugin it looks decent and does a quite good job. But a really annoying thing is, when I delete the entire message using the backspace key, then i get this annoying windows error sound. I have all sounds disabled! however it still appears, please remove this sound or add a option for the users to deactivate this.

Thanks and best regards
geskill
Last Edit: October 14, 2010, 16:01:53 by geskill
#2
Re: nasty sound when using the backspace key in a empty messagebox |
October 14, 2010, 17:04:40
It's a standard windows sound effect. No way to remove it in the plugin, you'll have to do this elsewhere.

TabSRMM doesn't play sounds when typing unless you enable this feature.

BTW: I do not get this sound when i use the "No sounds" scheme in Windows. So I'm pretty sure it's a configuration problem on your side.
__
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
My SMF-based forum fork
#3
Re: nasty sound when using the backspace key in a empty messagebox |
October 14, 2010, 17:23:05
It's a standard windows sound effect. No way to remove it in the plugin, you'll have to do this elsewhere.
i would say possible is everything, cause i'm too a application developer, but i'm not familiar with the plugin system so i don't know how much you can customize (i.e. disable BeepOnError)

TabSRMM doesn't play sounds when typing unless you enable this feature.
thats not the point

BTW: I do not get this sound when i use the "No sounds" scheme in Windows. So I'm pretty sure it's a configuration problem on your side.
of cause, but i mean the "No sounds" in the miranda options "Customize -> Sounds"

---
however i disabled the windows sounds
#4
Re: nasty sound when using the backspace key in a empty messagebox |
October 14, 2010, 17:25:51
I do not see any reason to take action, because it works as it should. There is no error sound when typing, no matter what sound scheme I use in Windows.

Just tested this on Win7 with most recent version of Miranda and TabSRMM 3. "Bug" not reproducible, also, you are the first one reporting this and I highly doubt nobody ever noticed it. So it must be something special to your system.
__
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
My SMF-based forum fork
#5
Re: nasty sound when using the backspace key in a empty messagebox |
October 14, 2010, 17:47:19
__
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
My SMF-based forum fork
#6
Re: nasty sound when using the backspace key in a empty messagebox |
October 14, 2010, 18:21:52
Sure, but in my applications i can disable this for each control individually =)
#7
Re: nasty sound when using the backspace key in a empty messagebox |
October 14, 2010, 18:24:07
Sure, but in my applications i can disable this for each control individually =)

Which is a very bad idea to do, because it's the job of the os and there are certainly users who WANT to hear such notifications.

So I'm not going to do this.
__
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
My SMF-based forum fork