YesNoOk
avatar

.97 - Birthday release (Read 28608 times)

Started by Nightwish, July 23, 2005, 16:55:30

0 Members and 1 Guest are viewing this.
Share this topic:
#51
Re: .97 - Birthday release |
September 01, 2005, 18:48:31
Nightwish: Are you planning to release a new version with png- and loadavatars-support? ;D

Yes. Loadavatars will be required by the next tabsrmm release. fully transparent and alphablended contact pictures are possible (of course, only locally set contact pictures will allow this, because neither icq nor msn avatars support that) with gdi+ rendering.
__
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
My SMF-based forum fork
#52
Re: .97 - Birthday release |
September 01, 2005, 20:03:03
Sounds good, thank you :)
#53
Re: .97 - Birthday release |
September 04, 2005, 09:39:29
Talkin' about locally set pictures, I've tried a CVS build compiled on August 30 and the avatar menu option is not working for me; no dialog is open on clicking it. Maybe the code was incomplete at that time, or maybe the old issue with not working link (Load local picture as avatar) reemerged. I just wanted you to know it.
Also, it seemed to crash quite often for no visible reason, so I thought -a stab in the dark- that the crashes could be the result of avatar service being used simultaneously in clist_modern and tabSRMM. I reverted to an August 24 CVS build that seems to work fine here.
Both builds are ANSI versions and still run on Win98SE (updated), just for the sake of clarification.
Oh and I have gdiplus 5.1.3102.1360 installed and I have tested all the imported functions from all dependent modules: they're loaded OK.
#54
Re: .97 - Birthday release |
September 04, 2005, 13:09:23
Talkin' about locally set pictures, I've tried a CVS build compiled on August 30 and the avatar menu option is not working for me; no dialog is open on clicking it. Maybe the code was incomplete at that time, or maybe the old issue with not working link (Load local picture as avatar) reemerged. I just wanted you to know it.
Also, it seemed to crash quite often for no visible reason, so I thought -a stab in the dark- that the crashes could be the result of avatar service being used simultaneously in clist_modern and tabSRMM. I reverted to an August 24 CVS build that seems to work fine here.

The option to set a local picture requires a recent release of the avatar service, because this functionality is no longer in tabsrmm itself. I'am not sure which version you were running. Also, I'am not sure in which state the code was on Aug.30 - there were at least 2 commits after that day.
__
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
My SMF-based forum fork
Last Edit: September 04, 2005, 13:32:45 by Nightwish
#55
Re: .97 - Birthday release |
October 10, 2005, 21:00:53
Using .97 tabsrmm and 0.9.13.4 MetaContacts the following issue occurs: if metacontact dialog window is not open, when a message arrives from metacontact, both miranda and tabsrmm icons blinks in system tray.
Is this tabsrmm issue, or something wrong with other plugins?
#56
Re: .97 - Birthday release |
October 10, 2005, 23:28:12
Using .97 tabsrmm and 0.9.13.4 MetaContacts the following issue occurs: if metacontact dialog window is not open, when a message arrives from metacontact, both miranda and tabsrmm icons blinks in system tray.
Is this tabsrmm issue, or something wrong with other plugins?

It is normal.
__
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
My SMF-based forum fork
#57
Re: .97 - Birthday release |
October 11, 2005, 11:30:39
Using .97 tabsrmm and 0.9.13.4 MetaContacts the following issue occurs: if metacontact dialog window is not open, when a message arrives from metacontact, both miranda and tabsrmm icons blinks in system tray.
Is this tabsrmm issue, or something wrong with other plugins?

It is normal.

In this case, how can i force miranda icon not to blink on new messages at all? Coz i don't like two same icons blinkin in system tray...
Or this bug will be fixed in next release?
#58
Re: .97 - Birthday release |
October 11, 2005, 14:25:15
In this case, how can i force miranda icon not to blink on new messages at all? Coz i don't like two same icons blinkin in system tray...

You can disable icon blinking in the clist or disable tabSRMMs own tray icon.

Quote
Or this bug will be fixed in next release?

It's not really a bug, but hard to avoid.

Edit
What may help is to disable the "Keep subcontact history synchronized with MetaContact" option on the Optons->Contact List->Meta Contacts page. If you have this option checked, then events will appear twice (one for the subcontact, one for the master contact of the MetaContact). Also, the option will waste a lot of db space, because each incoming message is duplicated from the subcontact to the metacontact. If the option is unchecked, the message is forwarded instead.
__
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
My SMF-based forum fork
Last Edit: October 11, 2005, 15:26:55 by Nightwish
#59
Re: .97 - Birthday release |
October 22, 2005, 17:55:52
I know i shouldn't be asking this but is a new release coming soon ;D ? It's been 3 months since the last release ...